Jump to content
The Classic Speaker Pages Discussion Forums
Sign in to follow this  
srkitchens

recommendation on Transformer hum - Powered Large Advents

Recommended Posts

When powered up there is a noticeable vibration on the APALs.  It is not coming from the Woofer but metal Amp mounting on the back side of the unit.  Just soliciting opinions on how to silence the vibration (only noticeable at no or very low volume).

Thanks in advance

Share this post


Link to post
Share on other sites

Yeah, eliminating mechanical vibration in a transformer can be a challenge. Clamping can help but anything short of disassembly and potting/repotting is a toss-up. What kind of trannies are they? Regular frame-wound or enclosed?

Doug

Share this post


Link to post
Share on other sites

I would say frame-wound  - I've attached a picture of a matching transformer from another unit.  Any recommendations on what type of glue to use if I decide to repot the unit? 

Thanks

Transformer.jpg

Share this post


Link to post
Share on other sites

Yeah, open frame. It looks like it was dipped/saturated in varnish when built. I think I might try just dipping it in the same thing again and hope the new varnish soaks in and fills any gaps or breaks.

Doug

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×